Ubuntu 14.10 Utopic Unicorn review - No rainbows

Updated: November 5, 2014

Autumn season, rain and distros, both hailing down on us, like the proverbial, eh, rain. Yes, twice a year, developers pump out fresh releases from their digital forges, and our never ending hunt for the perfect distro begins anew. With Trusty having set the bar so high, the challenge is ever more so exhilarating.

As always, I will begin with Ubuntu, then slowly branch onto the multi-lettered siblings of the family, and then test other distributions. The latest Canonical release is named Utopic Unicorn, and it's a somewhat silly name. But then, what does it matter. Follow me.

Live sess ... what the hell

All right, the only reason you are actually reading a review is because I'm a persistent little bugger. But things went downhill the moment I booted into the live session. It started with screenshots.

Desktop, live

The first one was fine, and you can actually see the desktop. But then, when I tried to take screenshots of the Dash and show how the search function works, with some rather weird and random results shown for video and music queries, the screenshot program would only return either an empty desktop, a partial capture of the Dash or something captured in its buffer from about twenty to thirty seconds back. I tried taking fresh new screenies of programs and the installer wizard, but the results were the same. Horrible.

Failures, all over

At this point, I was so angry I actually force-powered down the laptop, tried again. Consistent results. I redownloaded the image, burned it again, still no luck. This is an inherent bug, and I am amazed to see it come to bear on a fairly generic Intel-based laptop, which we have used for testing at least a hundred times before.

Then, the installer decided to misbehave. I marked a previous openSUSE install as the target partition, selected it for formatting with Ext4, and then, waited and waited. The installer failed to format the partition! Yes! In the end, I had to leave the previous filesystem in place, as this was the only way to make the installer work.

You have seen similar problems with Fedora, ROSA and Mageia, and I quit those attempts completely. Here, things were still sort of working, so at this point, I was kind of limping along, but the initial impression was one of WTF and CRAP. A horrible and inexplicable regression.

Trying to use the Urethric Unifail

The installation did succeed, eventually. After the installation, I booted into a system that looked sane. The first screenshot worked fine, but the moment you start fiddling, any subsequent one is going to be a ghost of some past, random imageĀ of something one of the ugly X components or whatnot have retained in its memory space somewhere.

Desktop installed

I tried updating the system, to see whether the new set of binaries would help cure this malady. Not only did not the new kernel patches and such fix anything, the universe and multiverse repo contents were missing on the local mirror. And I have no screenshots to actually show and prove anything. Screw this. We're done.


I'm so damn pissed off right now. Thank you, Ubuntu, thank you very much for ruining my weekend. I was so looking forward to doing some proper, fanboyish testing, and this had to happen. Why? Trusty was bloody flawless. Why this nonsense all of a sudden?

I am willing to extend the slight benefit of doubt to the Ubuntu family and retest on different hardware sometime in the future, as well as give Kubuntu and Xubuntu their due spin and such. But if this turns out to be legacy hardware issues so to speak, then we will be having an essay in expletives. Anyhow, skip this. Stay with Trusty, it's awesome and stable and fun. And let's see what the rest of the pack can do. For now, Unicorn, 0/10.